Testing server - program won't load

Discussion in 'Setup & Installation' started by psyche, Jul 24, 2007.

  1. psyche

    psyche New Member

    I recently downloaded the server and client to test the program; I am running it all on the same computer per the instructions at http://synapsedirect.com/forums/thread/379.aspx. I run the server, and when I open and login to the client a window just says "Acquiring encrypted tcp channels..." and does nothing else - I have left it like this over-night and nothing happened. What can I do to run the client?
  2. Graham

    Graham Developer Staff Member

    1. Is the server actually running? You will see a server console come up if it is. It will also say in the console what port it is running on.
    2. Since the server is on the same PC as the client, you need to tell the client to look on the local PC.
    • Click on the "Server" button on the login screen.
    • Change the server address to: where nn is the port in step 1

    and that should work ... login only takes less than a second when it is configured correctly.
  3. Jason

    Jason Developer / Handyman Staff Member

    [quote user="Graham"]
    1. Is the server actually running?[/quote]

    To run the server double click synapse-server.exe.

    It should look like this picture below.

    Attached Files:

  4. panthar

    panthar New Member

    I have same problem. It does not move furtherthan this. I created a user in environment variable as "skin" .. now I dont know what is the password .I am trying the password as "Guest" ...

    I dont understand what us happenning .... please help ....

  5. Graham

    Graham Developer Staff Member

    When you start the server (dbl click on synapse-server.exe), what exactly happens?

    What are you using for a server?

    What operating system?

  6. chompiropo

    chompiropo New Member

    I've a similar problem. On my Windows XP Professional Edition I launch the client, but then, when I press OK another screen pops up and tells "Acquiring encrypted tcp channel" and stays there. I'm trying to connect to the demo server but wasted an hour on that, so I would thank you if you could tell me what is wrong.


  7. Jason

    Jason Developer / Handyman Staff Member

    That's odd.

    You probably got Synapse from the wrong location.

    The latest version is located on this page


    But you could probably just click on this link and get it.


    Once the 1 Meg synapse.exe file is downloaded just execute/run it.

    I don't think you'll get a good feel of Synapse by just downloading it and trying it. We really need to be able to provide downloaders with more videos how Synapse works. If you were interested in an EMR, I'd be happy to try to figure out if Synapse would work with your situation. I many many of the other EMRs and have no problems suggesting other products, if Synapse isn't for you.

    http://www.hsonet.org/strepthroat8.htm - here is something I made a (LONG TIME AGO) (Note: OMG it's Build 181 !)

    Let us know how it goes.

  8. chompiropo

    chompiropo New Member

    I downloaded the file you told me, which btw i already had, but no results. I'm thinking it might have something to do with the fact that I'm behind a router (my home router to build my wifi network) although I programmed it with a port forwarding scheme to let pass the 8000-8100 port range.

    I tried ping to your machine and I get reply, so that makes me moresuspicious on the port handling.

    Another fact: When you open the client, at the bottom line you have a "Status" label. Does it have to say anything next to it? This is because I do get nothing there, is empty.

    I read something about setting environment variables, but I think that has to do with setting up a server more than the client for the demo connection.

    Thanks a lot for your help!

  9. Jason

    Jason Developer / Handyman Staff Member

    This is what the Login should look like.

    I believe the synapsedirect demo is down.

    Attached Files:

  10. Jason

    Jason Developer / Handyman Staff Member

    The demo server was restarted as is working now

    Logging in with

    Guest / Guest (as login / pass) works.
  11. chompiropo

    chompiropo New Member

    At last! It was the server all the time, ha ha.

    Thanks a lot for your help, I'll now test the application.

  12. Jason

    Jason Developer / Handyman Staff Member

    As I said,

    I don't think you get a great feel for the application based on just logging into the demo server.

    I also don't know which patient is the best to demo.

    I logged into the demo server to test it for you and it was filled with test patients, which are likely incomplete.

    Graham and I have been concentrating on improving Synapse, not making a good demo experience !

    I'd love to hear your problems with the demo, it'll help me when I arrange some documentation for future demo'ers.

Share This Page