ISP shared hosting Rebol install quesiton

Discussion in 'Rebol' started by SAngeli, Sep 22, 2012.

  1. SAngeli

    SAngeli New Member

    I have a shared hosting plan with ssh and ftp access and am trying to see if I can install/run Rebol on a this kind of platform, according to the article posted on reobl website.

    This is what I get for understanding the distro name and version installed:

    #uname -a
    Linux ... x86_64 x86_64 x86_64 GNU/Linux

    # cat /proc/version
    Linux version 2.6.18-194.26.1.el5xen ( (gcc version 4.1.2 20080704 (Red Hat 4.1.2-48)) #1 SMP Tue Nov 9 13:35:30 EST 2010

    # cat /etc/issue
    CentOS release 5.5 (Final)
    Kernel \r on an \m

    1. Looking at the download page of rebol:
    - which version should I select: Graphical Applications or for Server Applications ?
    (I assume it should be Server Application being used for developing webpages)
    - which distro should I download and install based on what I above posted?
    2. Looking at the rebol-core.278-4-2.tar.gz file I find basically only one file to use being named "rebol". Is this correct?
    3. Where exactely should I place the downloaded file on the server? In cgi-bin perhaps or it just does not make any difference because I will later tell the web server where to find the REBOL program that I just added?
    4. As I have a multi domain hosting plan, should I install/copy this file in each domain folder or not?
    5. This is the command to run "#!/home/your-account/rebol -c" to tell the webserver where rebol is located. /your-account/ is it equal to the entire path up to the file rebol correct? (Sorry for this question but just need to make sure.)

    PS: Keep in mind I do not have admin priviledges to the server. I can olny ftp and ssh as user

    Once I have done this and changed the permission of this file to chmod +x rebol how to I run my code? don't I have to reference the link to this file/path?

    Thank you,
  2. SAngeli

    SAngeli New Member

    If I wish to remove Rebol, after deleting the file, what should I type to tell the system that Rebol is not present anymore? (kind of undeclared it)?
    Thank you,
  3. Graham

    Graham Developer Staff Member

    if you have access to /bin then put it there, or /sbin
    and then chmod it to make it executable.
    Yes, "rebol" is the only file.
    No need to do anything once you remove it.
  4. SAngeli

    SAngeli New Member


    no, I do not have access to /bin. I can only acess my home directory as most common shared hosting plans.

    Rebol states that it is pobbile to run it on a shared hosting plan. Those plans have administrtive restrictions and this is why they state it is possible.

    What I need to know is which version should I select, for which distro should I download, where exactely should I place the downloaded file.
    Than I wish to know if after running #!/home/your-account/rebol -c" I have to run someting similar with anothe switch to remove it or not?

    This will enable me to perform a test as I need to verify this.

    Thank you,
  5. Graham

    Graham Developer Staff Member

    I'd suggest you ask your ISP where you can store executables.

    I put mine into my cgi-local and that works for me. But you may not have such a directory setup for you.

    I'd suggest using

    The -c switch just means run Rebol in cgi mode .. it's not an installation switch. You need that switch each time you use it as CGI.
    If you want to remove Rebol later, just delete it. It doesn't do any installation type things that need to be reversed.
  6. SAngeli

    SAngeli New Member

    Hi Graham,
    to be sure, is the link you provided me with for file download equivalent of "Linux x86 Libc6" "" "2-Jan-2011" "rebol-core-278-4-2.tar.gz" ?
    Thank you,
  7. SAngeli

    SAngeli New Member

    I was able to make Rebol function.
    1. I wait for the reply on the distry name so that next time I know what to download.

    I tried to impement a simple rebol cgi test and when I execute it from the web I get this:

    Finger protocol loaded Whois protocol loaded Daytime protocol loaded SMTP protocol loaded ESMTP protocol loaded POP protocol loaded IMAP protocol loaded HTTP protocol loaded FTP protocol loaded NNTP protocol loaded Script: "Server Time" (none) content-type: text/html

    <HTML> <BODY>
    Date/time is: 24-Sep-2012/11:02:56-4:00
    This is my test.
    </BODY> </HTML>

    I get the same output (up to before the html tag) when I run from Shell rebol.
    2. Is it normal to see all those data? How to avoid seing these?

    Thank you,
  8. Graham

    Graham Developer Staff Member

    That is what the -c switch is ... to suppress all those messages in CGI mode
  9. SAngeli

    SAngeli New Member

    Thank you all.
    This question is resolved and all works perfectly.


Share This Page